Workflow comments are intermittently unavailable if you have Slack integrated

Incident Report for Productiv, Inc.

Resolved

The fix to remove the dependency on Slack APIs has been rolled out. Slack API issues have also been less frequent, but we don't expect any further down time even if they regress.

Workflow comment functionality for customers with Slack integrated is completely restored.

Outgoing Slack notifications will continue to be degraded until Slack recovers. Our notifications will continue to be retried until they succeed, so we are calling this resolved.
Posted Feb 26, 2025 - 11:04 PST

Monitoring

We have deployed a fix to load the comments section without a hard dependency on Slack APIs. We are monitoring if it has resolved the issue for customers.

Outgoing Slack notifications will continue to be degraded until Slack recovers. Our notifications will continue to be retried until they succeed.
Posted Feb 26, 2025 - 10:50 PST

Identified

Slacks API outage is causing issues with our workflow comments section if the Slack integration is enabled for you (https://slack-status.com/2025-02/1b757d1d0f444c34)

We are mitigating the issue, by removing the existing dependency where possible, and should have a fix to start loading comments again shortly. To fully resolve the issue and all functionality, we are awaiting resolution from Slack on their API issues.

Outgoing Slack notifications will continue to be degraded until Slack recovers. Our notifications will continue to be retried until they succeed.
Posted Feb 26, 2025 - 08:30 PST

Investigating

Workflow comments are sometimes unavailable if you have Slack connected. It looks like we are currently effected by a Slack API outage, causing issues with our workflow comments section if the Slack integration is enabled for you (https://slack-status.com/2025-02/1b757d1d0f444c34)

Outgoing Slack notifications from the product are also degraded
Posted Feb 26, 2025 - 07:30 PST
This incident affected: Application.